Tawerna Bibliotekarzy
Kozie forum :)

Księga Skarg i Zażaleń - Problem z avatarem

Hutnuk - 2005-02-22, 08:50
Temat postu: Problem z avatarem
Heh to chyba jakiś mały problem ale przy kopiowaniu avatara dostaję taki komunikacik:
Kod:
Warning: copy(./images/avatars/1268486627421ae3849534e.jpg): failed to open stream: Permission denied in /data/members/free/tripod/uk/l/e/o/leoncoeur/htdocs/phpbb/includes/usercp_avatar.php on line 227

Warning: Cannot modify header information - headers already sent by (output started at /data/members/free/tripod/uk/l/e/o/leoncoeur/htdocs/phpbb/includes/usercp_avatar.php:227) in /data/members/free/tripod/uk/l/e/o/leoncoeur/htdocs/phpbb/includes/page_header.php on line 613

Warning: Cannot modify header information - headers already sent by (output started at /data/members/free/tripod/uk/l/e/o/leoncoeur/htdocs/phpbb/includes/usercp_avatar.php:227) in /data/members/free/tripod/uk/l/e/o/leoncoeur/htdocs/phpbb/includes/page_header.php on line 615

Warning: Cannot modify header information - headers already sent by (output started at /data/members/free/tripod/uk/l/e/o/leoncoeur/htdocs/phpbb/includes/usercp_avatar.php:227) in /data/members/free/tripod/uk/l/e/o/leoncoeur/htdocs/phpbb/includes/page_header.php on line 616

Jakieś pomysły?:)

EDIT---------------

W niektórych przypadkach pojawia się tez jajcarski tekst:
Cytat:
Rozmiar emblematu musi być większy niż 0 kB i mniejszy niż

Amon - 2005-02-22, 09:17

Cytat:
Rozmiar emblematu musi być większy niż 0 kB i mniejszy niż


Mam to samo :evil:

Hmm... na forach się nie znam ale z doświadczenia z paroma programami podejżewam że może nie rozpoznaje tego formatu plików :?:

Oczywiście to tylko przypuszczenie lamera :wink:

Hutnuk - 2005-02-22, 09:34

I na pewno problem nie dotyczy rozmiaru bo ja juz probowalem wcisnąc takiego co ma 2kb wiec... <hutnuk_confused> :evil:


EDIT---------------------

Ok, najwyraźniej już działa... :?

Leoncoeur - 2005-02-22, 12:03

blad naprawiony, cieszcie sie ludziki,
wszyscy mozecie znow wrzucac aviki.
nie bedzie przyjemnie jak znów sie popsuje
na razie jest dobrze, wiec temat blokuje...


--------edit

falszywy alarm choc bardzo zaluje...
Amon znow blad ten nam raportuje.
niefajnie sie dzieje naprawiac bedziemy
lecz kiedy skonczymy, to sami nie wiemy...



normalnie KKZ... :(

Kermit - 2005-02-22, 15:59

Czy może ktoś spróbowac załadowac avika teraz?

Kermit.

Grzebul - 2005-02-22, 16:11

Spróbowałem. Mi działa. 8)
Kermit - 2005-02-22, 16:23

Hut i Amon wiem, że macie ten sam problem.

Powiedzcie tylko jedno. Jak wstawiacie avika? Z kompa? A spróbujcie wstawić z netu, co?
Wiem, że taki przypadek był na jednym forum i z net chodziło, a z kompa nie :D

Kermit.

Hutnuk - 2005-02-22, 16:26

Kermit napisał/a:
Hut i Amon wiem, że macie ten sam problem.

Nie no mi sie problem "sam" chyba naprawił. I też już myslalem zeby z netu wstawic ale w koncu zaskoczyło z kompa wiec dalem sobie spokoj.

Amon - 2005-02-22, 19:00

Dobra wkleiłem sobie avka do albumu i teraz działa :wink:
Zapi - 2005-02-23, 13:50

A ja mam problem, bo mi nie chce się łączyćz adresem, który podaje.
Grzebul - 2005-02-23, 15:07

Elrond: A co się pokazuje?
Może zły adres wpisałeś?

Zapi - 2005-02-23, 15:12

Adres wpisałem dobry a pisze że się połączyć nie może...:wink:

Spróbuj z innym adresem, jeśli będzie wchodził, znaczy, że to wina tej stronki, z której chcesz zaimportować avatar i my Ci nic w tym nie pomożemy.

Grzebul - 2005-02-23, 15:15

Sprawdź czy strona obrazka działa.
Czy nie jest za duży...
Wtedy może spróbu wrzucić obrazek do własnej galeri w albumie, i dać linka stamtąd...

Zapi - 2005-02-23, 15:19

Strona działa a rozmiar obrazka = 100 x 100 a z galerią spróbuję.
Orzecho - 2005-02-23, 16:41

Hmm... z tym 100 x 100 to nie wiem... bo domyślnie w phpbb jest chyba 80 x 80... ale Leon albo Vil mogli zmienić.... Spróbuj o ja zwykle spotykałem włożyć z kompa. Ja zwykle się spotykałem z przypadkami, że z netu nie działa a z kompa, tak. Może to jakiś błąd nie błąd w kodzie typu, że system sobie od razu wpisuje http czy coś w tym stylu. Więc spróbuj pokombinować.
Hutnuk - 2005-02-23, 17:03

Limit wielkości avika tu (jak łatwo sami sobie możecie przeczytać w profilu, wystarczy kliknąć) to: 100 x 100 pikseli, a rozmiar nie większy niż 12kB. Możliwe, że problem nie leży w tym jakie ma wymiary ale jaki rozmiar bo 12 kB można przekroczyć łatwo jeśli to jpg.
Kermit - 2005-02-23, 17:55

Przykro mi, ale naprawdę nie wiem co jest z tymi avikami. CHMODy są ustawione i to dobrze, w kodzie żadnego błędu nie ma :/ . Ehh ... *urna!!

Kermit.

Proszę nie przeklinać :twisted:

Horus - 2005-03-02, 18:42

To chyba wina przeniesienia forum na inny serwer, ale problem z avatem znów wrócił... I chyba nie tylko ja mam ten problem.

EDIT: Ten post napisany przez "gościa", jest mój, zapomniałem się zalogować... :P

EDIT: Cholera, znowu zapomniałem o loginie, ostatni raz... :?

Zapi - 2005-03-02, 18:47

to ze strony z avem weź zgraj na kompa jako .jpg .gif itp. i go wsadź z kompa!!! powinno działać
Gość - 2005-03-02, 18:55

Na starym forum, limit wielkości pliku był 12kb, a teraz w moim profilu, jes 1kb... :?
Vilkatla - 2005-03-02, 19:00

Już jest 12, mój błąd :)
Horus - 2005-03-02, 19:24

Pospieszyłem się... Tym razem nie przyjmuje ani formatu gif, jpg, png. Próbowałem z różnymi rozmiarami, ale nadal nic. :?

Nie wiem, dlaczego tak się stało, ale przy przenosinach część avatarów zaginęła w akcji... Trza poczekać na Technika, ja tutaj chyba nic nie poradzę :/

Orzecho - 2005-03-02, 19:48

A może spróbuj tak jak Amon? Najpier do galerii i potem link?

Cytat:
ie wiem, dlaczego tak się stało, ale przy przenosinach część avatarów zaginęła w akcji... Trza poczekać na Technika, ja tutaj chyba nic nie poradzę :/


Jakim wy ftp to przekładaliście?

Kermit - 2005-03-02, 20:34

Heej, ani jeden vik nie zginął w akcji. Wszystkie są przegrane. Już sprawdzam czemu nie zaskoczyły.

Żeby nowy avik zaskoczył musicie wgrać obrazek na serwer w necie i podać link aby stamtąd ładował. Jeżeli nie macie gdzie wrzucic ślijcie do mnie, a coś z tym zrobię :D

Kermit.

Horus - 2005-03-03, 17:16

Żabciu :D ... gdyby to takie proste było... Wrzuciłem na serwa a tu :
Cytat:
Warning: tempnam(): open_basedir restriction in effect. File(/tmp) is not within the allowed path(s): (/home/users/biblioteka/www) in /home/users/biblioteka/www/forum/includes/usercp_avatar.php on line 148

Warning: Cannot modify header information - headers already sent by (output started at /home/users/biblioteka/www/forum/includes/usercp_avatar.php:148) in /home/users/biblioteka/www/forum/includes/page_header.php on line 613

Warning: Cannot modify header information - headers already sent by (output started at /home/users/biblioteka/www/forum/includes/usercp_avatar.php:148) in /home/users/biblioteka/www/forum/includes/page_header.php on line 615

Warning: Cannot modify header information - headers already sent by (output started at /home/users/biblioteka/www/forum/includes/usercp_avatar.php:148) in /home/users/biblioteka/www/forum/includes/page_header.php on line 616


:? ...

Orzecho - 2005-03-03, 17:43

Hmm... to są błędy w kodzie co nie? A nie w obrazku... Nie wiem jak to się dzieje, że mi jakoś działa ;) SoO, może jakiś serwer nie taki? chociaż wtedy by wyświetlało inny obrazek... ja mam problem z avatkami na każdym forum jakie zakładam i na każdym znajduje się inny sposób ;) Popróbój wszystkich możliwości :D najpierw wrzuć do galerii, potem wrzuć na serwer, dać z adresu.
Amon - 2005-03-03, 18:56

Ozyrson, zrób to tak:
Po pierwsze umieszczanie zdjęc
Najprostsza metoda to http://www.imageshack.us/
trzeba sie wpierw zarejestrować(prosta rejestracja polegająca na podaniu adresu email i aktywowaniu klucza który zostnaie przysłąny na email), po rejestracji na głównej stronie wybierasz "wybierz" i "host it" powinno zacząć uploadować obrazek na serwer. Po tym wyświetla się panel z obrazkiem, w jednej z komórek pisze [img ]link[/img ],
i ten link wpisuje się w treści posta.


To swojego czasu napisał Serafin na bibliotece. Ja w ten sposób rozwiązałem problem avatara, ten aders o którym mowa podałem w "Wyślij Emblemat z adresu" czy "Odnośnik do zewnętrznego Emblematu" (nie pamiętam dokładnie :wink: . Jak sprytny jesteś to sobie poradzisz, wierzę w ciebie :wink: ("wieŻę też... :wink: )

Horus - 2005-03-03, 21:44

Ta Amonicie (;)), spróbujemy... może wreszcie się uda. Dam znać co i jak.
Kermit - 2005-03-03, 22:02

"Odnośnik do zewnętrznego Emblematu" - to musisz wybrać SoO. A czemu sa problemy? HGW (interpretować jak kto chce :P )

Kermit.

Horus - 2005-03-03, 22:11

Hmmm... Więc problem był tak prosty w rozwiązaniu? ;) Dzięki bracia. :D
Iras - 2005-03-06, 20:42

No to i ja zadam pytanko? jak co mam zrobić żeby awatar miał te 12 kb a nie więcej???? bo niestety, w tej chwili mam 13 kb i nie mam pojęcia jak to zmienić...
Amon - 2005-03-06, 20:45

Jak masz np przeglądarke ACDSee to zapisz ten obrazek jako *.jpg ale w opcjach zapisu przesuń pasek kompresji.

Albo prześlij mi mailem/gg to ja to zrobię :wink:

Karry - 2005-03-06, 20:45

Możesz zmniejszyć rozmiar albo poprosić admina o zwiększenie limitu

PS - cześć Iras :)

Iras - 2005-03-06, 20:49

masz na mysli rozmiar jako rozmiar? piksele? wątpię... jesli zmniejsze to jeszcze bardziej to bedzie to miało rozmiar 30 /40 więc wiesz... chyba raczej poprosze admina:P

ps . cześć:D

Vilkatla - 2005-03-06, 21:39

Zwiąkszyłam ciężar do 15kb, a rozmiar do 110x110.
Wieksze avy jakoś mi nie leżą :/

PS. Cześć Iras :) <hyh, wiem, że powitania gdzie indziej, ale nie mogłam się powstrzymać ;) >

Kermit - 2005-03-06, 22:26

Iras, jeżeli dalej nie bedzie wchodziło to prześlij mi ten avik na maila (jest w profilu). Włoże go ręcznie przez baze. Sorka,że tak prymitywne rozwiązanie, ale gonią mnie prace do zrobienia w szkole.

Kermit.

Orzecho - 2005-03-07, 21:11

Iras napisał/a:
masz na mysli rozmiar jako rozmiar? piksele? wątpię... jesli zmniejsze to jeszcze bardziej to bedzie to miało rozmiar 30 /40 więc wiesz... chyba raczej poprosze admina:P

ps . cześć:D


Możesz, zmniejszy ilość dpi albo zapisać jako gif. Gif ma większy poziom kompresji...

Zapi - 2005-03-07, 21:14

Orzecho napisał/a:
Iras napisał/a:
masz na mysli rozmiar jako rozmiar? piksele? wątpię... jesli zmniejsze to jeszcze bardziej to bedzie to miało rozmiar 30 /40 więc wiesz... chyba raczej poprosze admina:P

ps . cześć:D


Możesz, zmniejszy ilość dpi albo zapisać jako gif. Gif ma większy poziom kompresji...


Przy tym rozmiarze?!?! Nie to nie możliwe jak by było 100x100 to co innego by było. No chyba że to .bmp.
Tak lepiej admina poproś. A jak to nie podziała to daj se spokuj.

Orzecho - 2005-03-07, 21:18

Przepraszam ale co to ma do rzeczy? :?

Ja mam Operę to mogę przybliżać sobie stronę, i tak sobie patrzyłem. Większość z was może sobie spokojnie zmniejszyć dpi o połowę ;)

Kermit - 2005-03-08, 18:58

Ok avik JAR'a i Iras wrzucone. Jeżeli ktos ma jakieś problemy to walić do mnie, wrzucę te avik.

Iras, jakosci nie poprawiłem. Kiedy próbowałem to się spsuł obrazek. Więc ... jeżeli ktoś może, to prosze o przesłanie "ulepszonego" avika na mój mail.

Kermit.

Zapi - 2005-03-09, 20:05

A teraz ja mam problem bo ava zmienić chciałem ale mi pize że musi być .gif .jpg itd. choć jest albo że misi być mniejszy miż 15kb a jest 7,8kb?? o co biega?!?!
Horus - 2005-03-09, 20:39

Wyślij Kermitowi, potem pobaw się opcją, "odnośnik do zewnętrznego emblematu"... Było to wyjaśnione kilka postów wcześniej ;)
Orzecho - 2005-03-09, 20:40

Heh, a ja ładuje gifa i mi mówi, że złe rozszeżenie ;) a jak ładuje bez "" to się zgadza ale tego nie aktywuje... ***** straszne ;)

edit
Te, właśnie, Kermit ma uprawnienia admina? bo z panelu admina można te avy ładować ;)

Horus - 2005-03-09, 20:42

W takim wypadku, musicie rozmawiać z Technikiem ;)
Próbowaliście z albumem, albo wrzucaniem na serwa?

Zapi - 2005-03-09, 20:44

Ja próbowałem a do albumu mi wejść nie chce :wink:
Orzecho - 2005-03-09, 20:51

Próbowałęm, też coś nie wychodziło... jakieś kłopoty z obrzkiem czy cóś...
Horus - 2005-03-09, 20:56

Dalsze kontynuowanie tego jest bez sensu... Wyślijcie PW lub zagadajcie na gg do kogo trzeba. Wyczuwam tu woń... nabijania postów :twisted:
Jar - 2005-03-10, 10:38

Żeby zakończyć te ciekawe rozważania wystarczy wysłać własnego awatara na adres Kermita jest w profilu a on załatwi reszte co widać po moim którego też nie mogłem sam umieścić.
Hergath - 2005-03-10, 17:43

Oszaleliście z tymi ogłoszeniami globalnymi ?! Najpierw tema żeby się bać bo tu rządzi Wilczur, teraz jakieś awatary. Jak ktoś bedzie miał problem to znajdzie odpowiedni dział. A nie brdel robićie. Ja ava nie miałęm przez 1 dizeń ale teraz działa, i jest z dysku. Nie przejmowałem sie avem bo to tylko bzdetny obrazeczek. Sa ważniejsze sprawy. Avy radze zapisywac w gif, mniejszy, ładniejszy.
Orzecho - 2005-03-10, 19:33

O, udało się... ja włożyłem z adresu.... tylko w tym drugim, bez kopiowania ;)
Vilkatla - 2005-03-10, 22:03

Tiaa... z tym 'globalnym' to lekka przesada. Zmieniam na zwykłe.
Hergath -> proszę, nie czepiaj się mojej pomyłki z Wilczurem :> To naprawdę nie było umyślne.

Hélegorn - 2008-03-11, 21:50

Próbuję zaktualizować adres pliku z avatarem (korzystając z opcji "Odnośnik do zewnętrznego obrazka"), ale skrypt się stawia...
'Kochany' Przemo napisał/a:
Podany adres obrazka nie jest prawidłowy
Oczywiście jest to nieprawda, adres jest prawidłowy, co widać na załączonym poniżej obrazku:



Da się coś z tym zrobić? :(

Orzecho - 2008-03-16, 10:03

Może użyj "Wyślij obrazek z adresu:" ? Pamiętam, że z avatarami u przema były zawsze problemy i często działało wybranie drugiej opcji ;)
Hélegorn - 2008-03-16, 16:26

Nie chcę wgrywać avatara na serwer.

Dlaczego nie? Bo nie. :P

Coincidence - 2008-03-16, 18:18

Zapisz avatar na pulpicie i wgraj w profilu? :P
Orzecho - 2008-03-16, 18:32

No przecież powiedział, że nie chce wgrywać na serwer :P Jak z pulpitu załaduje to wgra na serwer, nie?

Cytat:
Dlaczego nie? Bo nie.


No tak, w nocy mogą ukraść.

Vilkatla - 2008-12-06, 00:24

hm, z tymi avatarami jest caly czas jakis problem ;>
nijak nie da sie wrzucic, ani z kompa, ani z adresu, ani przez odnosnik:
Cytat:
Twoja lokalizacja zawiera za dużo znaków

wtf ?

Grzebul - 2008-12-06, 00:55

Hmm
Chyba generalnie chodzi o to Vil, że Twoja lokalizacja zawiera za dużo znaków.

Amon - 2008-12-06, 20:47

Grzebul napisał/a:
Chyba generalnie chodzi o to Vil, że Twoja lokalizacja zawiera za dużo znaków.

to jest całkiem prawdopodobne, ten trop też nalezalo by zbadać

Vilkatla - 2008-12-07, 12:59

lol, wkleilam nie ten blad, co potrzeba ;D
mialo byc:
Cytat:
Podany adres obrazka nie jest prawidłowy


a przy probie wgrania z dysku:
Cytat:
Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move '/tmp2/phpIjpC5E' to './images/avatars/307704333493bbb1b7ed2f.jpg' in /home/users/biblioteka/www/board/includes/usercp_avatar.php on line 355


lub wyslania z adresu:
Cytat:
Could not write avatar file to local storage. Please contact the board administrator with this message

Amon - 2008-12-07, 13:03

W takim razie generalnie chodzi o to Vil, że podany adres obrazka nie jest prawidłowy
Vilkatla - 2008-12-07, 13:04

kiedy wlasnie jest jak najbardziej prawidlowy :(
Kermit - 2008-12-07, 13:22

Obadajcie teraz czy śmiga ;)

Kermit.

Vilkatla - 2008-12-07, 14:29

dziala :]
Yarpen - 2008-12-07, 20:30

"Fajny kocur bejb". :P

Powered by phpBB modified by Przemo © 2003 phpBB Group